event-sim/nixos/systems/simhost1/simhost1.nix
fly 85aa2a9845 Enable auto login
Signed-off-by: fly <merspieler@alwaysdata.com>
2024-06-01 19:40:25 +00:00

38 lines
730 B
Nix

{ config, lib, pkgs, ... }:
{
imports = [
./hardware-configuration.nix
../../configs/base.nix
../../configs/desktop-base.nix
../../configs/desktop-i3.nix
../../configs/flightgear.nix
];
environment.systemPackages = with pkgs; [
killall
];
systemd.tmpfiles.settings = {
i3-config."/home/fly/.config/i3/config"."L+" = {
argument = "${../../../config/i3.conf}";
};
};
services.xserver.displayManager = {
autoLogin = {
enable = true;
user = "fly";
};
};
boot.loader.grub.enable = true;
# boot.loader.grub.efiSupport = true;
boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
networking.hostName = "simhost1";
system.stateVersion = "23.11"; # Did you read the comment?
}